Follow

arcserve-KB : UDP | Installer || Error during upgrade from UDP 5 to 6

Last Update: 2018-03-27 15:27:28 UTC
Description:
Upgrade from UDP version 5 to Version 6 fails if the following condition matches:
SQL: Full version
Instance name: Arcserve_APP

In this scenario the installation fails with the following error:

SilentInstall.log

2016-07-15 15:33:09 | LaunchProcess: return 0 with ExitCode 8

2016-07-15 15:33:09 | Install Microsoft SQL Server 2014 Express Failed
2016-07-15 15:33:09 | Setup interrupted for Microsoft SQL Server 2014 Express blocks the process
2016-07-15 15:33:09 | Fail to Install prerequsites for software. So stop the program.
2016-07-15 15:33:09 | Exit with errorcode 10

 

ProdWiz.log

2016-07-15 15:31:47 | Arcserve\MSSQLE\200
2016-07-15 15:31:47 | Setup is installing Microsoft SQL Server 2014 Express on your computer.
2016-07-15 15:33:09 | The exit code of SilentInstall.exe is 10
2016-07-15 15:33:09 | Arcserve\MSSQLE\201\204
2016-07-15 15:33:09 | Setup was unable to install Microsoft SQL Server 2014 Express.
2016-07-15 15:33:09 | Installation incomplete.

 


C:/Program Files/Microsoft SQL Server/XX/Setup Bootstrap/Log/Summary.txt


Message:

The specified edition upgrade is not supported. For information about supported upgrade paths, see the SQL Server 2014 version and edition upgrade in Books Online.

HResult : 0x84be0212

FacilityCode : 1214 (4be)

ErrorCode : 530 (0212)


Solution:
-Edit the db_configuration.xml file which can be seen under the following path C:\Program Files\CA\Arcserve Unified Data Protection\Management\Configuration\.

-Check for the following line,
<dbURI>jdbc:sqlserver://localhost\ARCSERVE_APP;databaseName=arcserveUDP;integratedSecurity=true

-Replace localhost with the Hostname of the SQL Server in db_configuration.xml file.

-Default Path for the db_configuration.xml file: 
C:\Program Files\CA\Arcserve Unified Data Protection\Management\Configuration\

db_configuration.xml
<?xml version='1.0' encoding='UTF-8' standalone='yes'?>
<EdgeDBConfiguration>
<dbPoolMaxSize>20</dbPoolMaxSize>
<dbPoolMinSize>3</dbPoolMinSize>
<dbURI>jdbc:sqlserver://localhost\ARCSERVE_APP;databaseName=arcserveUDP;integratedSecurity=true</dbURI>
<dbUser></dbUser>
<firstStatements>SET DATEFORMAT ymd;SET DATEFORMAT ymd;</firstStatements>
<validateSql>select 1</validateSql>
<version>1</version>
</EdgeDBConfiguration>

Cause:
The reason for this installation failure is, by default the Installation process considers the 'localhost\arcserve_APP' entry in this file as SQL Express and without checking the version of the SQL installed, the installer tries to upgrade the full version of SQL to the Express Edition and it fails.

Once we replace the localhost with the actual host name of the SQL Server, the installer will try to identify the version of the SQL. bypass the SQL upgrade process and proceed with installation.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments