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arcserve-KB : UDP | Windows Agent || Arcserve UDP Agent Service never starts due to conflict with Avaya one-X attendant application

Last Update: 2018-02-01 16:10:46 UTC
Problem:  UDP agent service doesn't start

Environment: 
Arcserve UDP 6.0 GA, update 1, update 2 and update 3.
Arcserve UDP 6.5 GA, update 1.

Observation:
Avaya one-X attendant 4.14 is also installed on the same server 

Cause:
The root cause of this problem is after installing Avaya one-X attendant 4.14, it will put some jar files in java default ext folder C:\Windows\Sun\Java\lib\ext 
This will cause Arcserve UDP agent service not to start at all.

Solution:
1. Login to the problematic server.

2. Open the registry and go to this location -
 HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation\Procrun 2.0\CASAD2DWebSvc\Parameters\Java\

3. Select 'options' on the right side pane. Right click and select 'Modify'.

4. Add the below line. It should look like same as highlighted in the screenshot.

-Djava.ext.dirs=C:\Program Files\Arcserve\Unified Data Protection\Common\JRE\lib\ext



5. Click Ok and close the registry. Then start the UDP agent service.
6. Refresh the services and verify if UDP agent service is continuously running.
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